Skip to main content
OCram85.com

✨ PSCredentialStore 1.1.0 is released

·181 words·1 min·

PSCredLogo

Today I’m proud to present the release of PSCredentialStore version 1.1.0.

This version was mainly focused on updating the build pipeline and codebase. So let me explain the changes in detail:

  • 🧰 Reworked the build pipeline and replace Travis, AppVeyor by Drone.IO.
  • 🧰 Updated the PowerShell style to the lates community standards.
  • 🧰 Migrated from Github to self hosted Gitea.
  • 🧰 Migrated to self hosted Drone and Woodpecker CI.
  • 🧰 Updated Pester unit tests to Pester5+ syntax.
  • 💣 Changed from MIT to GNU AGPLv3 license.
  • 🧰 Removed the optional dependency helper.
  • 📦 Updated embedded OpenSSL (LibreSSL) files to version 3.5.3.
  • 🧰 Added gitea project template files for issues and pull requests.
  • 🤖 Implemented DroneHelper base Drone pipeline.

Additionally we fixed some issues and added new connection types:

  • 🌟 Added CiscoUCSCentral connection type
  • 🐛 Fixed Test-CredentialStoreItem output
  • 🐛 Fixed CiscoUCS connection

You can find the PSCredential store at PowerShell Gallery and gitea.ocram85.com.

Feel free to install or upgrade to the latest version with the following command.

Install-Module -Name 'PSCredentialStore' -Force

forthebadge